华为三层交换机与路由器对接上网配置示例

三层交换机简介

三层交换机是具有路由功能的交换机,由于路由属于OSI模型中第三层网络层的功能,所以称为三层交换机。  三层交换机既可以工作在二层也可以工作在三层,可以部署在接入层,也可以部署在汇聚层,作为用户的网关。

配置注意事项

本举例中的交换机配置适用于S12700, S12700E交换机的所有版本所有产品。本举例中的路由器配置以AR3600 V200R007C00SPCc00为例,其他路由器的配置方法请参见对应的文档指南。

组网需求

如图所示,某公司拥有多个部门且位于不同网段,各部门均有访问Internet的需求。现要求用户通过三层交换机和路由器访问外部网络,且要求三层交换机作为用户的网关。

配置思路

采用如下思路进行配置:

  1. 配置交换机作为用户的网关,通过VLANIF接口,实现跨网段用户互访。
  2. 配置交换机作为DHCP服务器,为用户分配IP地址。
  3. 配置路由器通过NAT转换,使用户可以访问外部网络。
  • 操作步骤
  1. 配置交换机

# 配置连接用户的接口和对应的VLANIF接口。

<HUAWEI> system-view
[HUAWEI] sysname Switch
[Switch] vlan batch 2 3
[Switch] interface gigabitethernet 1/0/2
[Switch-GigabitEthernet1/0/2] port link-type access   //配置接口接入类型为access
[Switch-GigabitEthernet1/0/2] port default vlan 2   //配置接口加入VLAN 2
[Switch-GigabitEthernet1/0/2] quit
[Switch] interface gigabitethernet 1/0/3
[Switch-GigabitEthernet1/0/3] port link-type access
[Switch-GigabitEthernet1/0/3] port default vlan 3   
[Switch-GigabitEthernet1/0/3] quit
[Switch] interface vlanif 2
[Switch-Vlanif2] ip address 192.168.1.1 24
[Switch-Vlanif2] quit
[Switch] interface vlanif 3
[Switch-Vlanif3] ip address 192.168.2.1 24
[Switch-Vlanif3] quit

# 配置连接路由器的接口和对应的VLANIF接口。

[Switch] vlan batch 100
[Switch] interface gigabitethernet 1/0/1
[Switch-GigabitEthernet1/0/1] port link-type access
[Switch-GigabitEthernet1/0/1] port default vlan 100   
[Switch-GigabitEthernet1/0/1] quit
[Switch] interface vlanif 100
[Switch-Vlanif100] ip address 192.168.100.2 24
[Switch-Vlanif100] quit

# 配置缺省路由

[Switch] ip route-static 0.0.0.0 0.0.0.0 192.168.100.1   //缺省路由的下一跳是路由器接口的IP地址192.168.100.1

# 配置DHCP服务器

[Switch] dhcp enable   
[Switch] interface vlanif 2
[Switch-Vlanif2] dhcp select interface   //DHCP使用接口地址池的方式为用户分配IP地址
[Switch-Vlanif2] dhcp server dns-list 114.114.114.114 223.5.5.5   //配置的DNS-List 114.114.114.114是公用的DNS服务器地址,是不区分运营商的。在实际应用中,请根据运营商分配的DNS进行配置
[Switch-Vlanif2] quit
[Switch] interface vlanif 3
[Switch-Vlanif3] dhcp select interface
[Switch-Vlanif3] dhcp server dns-list 114.114.114.114 223.5.5.5
[Switch-Vlanif3] quit

2.配置路由器

# 配置连接交换机的接口对应的IP地址。

[Huawei]system-view
[Huawei] sysname Router
[Router] interface gigabitethernet 0/0/1
[Router-GigabitEthernet0/0/1] ip address 192.168.100.1 255.255.255.0   //配置的IP地址192.168.100.1为交换机缺省路由的下一跳IP地址
[Router-GigabitEthernet0/0/1] quit

# 配置连接公网的接口对应的IP地址。

[Router] interface gigabitethernet 0/0/2
[Router-GigabitEthernet0/0/2] ip address 200.0.0.2 255.255.255.0   //配置连接公网接口的IP地址和公网的IP地址在同一网段
[Router-GigabitEthernet0/0/2] quit

# 配置缺省路由和回程路由

[Router] ip route-static 0.0.0.0 0.0.0.0 200.0.0.1   //配置静态缺省路由的下一跳指向公网提供的IP地址200.0.0.1
[Router] ip route-static 192.168.0.0 255.255.0.0 192.168.100.2   //配置回程路由的下一跳就指向交换机上行接口的IP地址192.168.100.2

# 配置NAT功能,使内网用户可以访问外网。

[Router] acl number 2001
[Router-acl-basic-2001] rule 5 permit source 192.168.0.0 0.0.255.255   //NAT转换只对源IP地址是192.168.0.0/16网段的生效,并在接口GE0/0/2的出方向进行转换
[Router-acl-basic-2001] quit
[Router] interface gigabitethernet 0/0/2
[Router-GigabitEthernet0/0/2] nat outbound 2001
[Router-GigabitEthernet0/0/2] quit
  • 检查配置结果

配置PC1的IP地址为192.168.1.2/24,网关为192.168.1.1;PC2的IP地址为192.168.2.2/24,网关为192.168.2.1。

配置外网PC的IP地址为200.0.0.1/24,网关为200.0.0.2。

配置完成后,PC1和PC2都可以Ping通外网的IP 200.0.0.1/24,PC1和PC2都可以访问Internet。

配置文件

交换机

#
sysname Switch
#
vlan batch 2 to 3 100
#
dhcp enable
#
interface Vlanif2  ip address 192.168.1.1 255.255.255.0  dhcp select interface  dhcp server dns-list 114.114.114.114 223.5.5.5
#
interface Vlanif3  ip address 192.168.2.1 255.255.255.0  dhcp select interface  dhcp server dns-list 114.114.114.114 223.5.5.5
#
interface Vlanif100  ip address 192.168.100.2 255.255.255.0
#
interface GigabitEthernet1/0/1  port link-type access  port default vlan 100
#
interface GigabitEthernet1/0/2  port link-type access  port default vlan 2
#
interface GigabitEthernet1/0/3  port link-type access  port default vlan 3
#
ip route-static 0.0.0.0 0.0.0.0 192.168.100.1
#
return

路由器

#
sysname Router
#
acl number 2001  rule 5 permit source 192.168.0.0 0.0.255.255
#
interface GigabitEthernet0/0/1  ip address 192.168.100.1 255.255.255.0
#
interface GigabitEthernet0/0/2  ip address 200.0.0.2 255.255.255.0  nat outbound 2001
#
ip route-static 0.0.0.0 0.0.0.0 200.0.0.1
ip route-static 192.168.0.0 255.255.0.0 192.168.100.2
#
return
转载请注明本文链接:https://blog.weixiaoline.com/567.html

发表评论

您的电子邮箱地址不会被公开。